Back to overview
Maintenance
System Maintenance
May 24, 2025 at 10:40am UTC
–
May 26, 2025 at 6:00pm UTC
Affected services
RPW Apps & Services
RPW Apps
RPW Database System
RPW DNS
Resolved
May 24, 2025 at 7:55pm UTC
The main servers are undergoing a major upgrade, and so will not be available for several days
Affected services
Created
May 24, 2025 at 10:40am UTC
System upgrades
Affected services